Saturday 1st August 2020

Garmin Activity Synchronization Garmin Sync is not working (again)

Update (5th August 8:30)

Garmin has fixed the issue and we are now processing all activities. This will take some hours.

Update (3th August) from Garmin

Garmin is fixing it, but it still could take some days

It seems that Garmin is having problems syncing to third parties via the Health API API. Unfortunately, the API is not giving us any activity file at the moment. ("Uploaded file not found)

As this problem is on Garmins side we have to wait.

We have disabled the Garmin Sync on our side until we are able to receive the activity files.

Garmin has confirmed the problem and is working to fix it.

Activities should appear after Garmin has fixed their issues.

It is also not possible to download the original FIT file directly from Garmin Connect at the moment.

Since some questions have arisen about why other platforms work:

Garmin basically has two APIs. An old one, which some still use for historical reasons and a "new one", to which we migrated back then as well. The difference is that with the old one, you get the file right away, and with the new one, you can pick it up whenever you (we) are ready (and you only get information that the user has a new activity). This is the reason why sync still works on some platforms.